Minimum System Requirements

v5.3.0 – October 2019

Core Modules

  • Fourth Analytics
  • Applicant Tracking (“ATS”)
  • Engage/Fourth app Inventory (“r9”)
  • Labour Productivity (“TeamHours”)
  • Purchasing & Inventory (“Adaco”)
  • Purchase-to-Pay (“Trade Simple”)
  • Recipe and Menu Engineering (“StarChef”)
  • HR/Payroll

Windows Desktop environment

Supported Browsers and Versions
We test and supports many of our core products in the following Windows browsers:
Microsoft Internet Explorer v11*
The most recent stable versions of the Chrome and Firefox browsers

Please note the following exceptions:

  • Engage/Fourth app is also supported in the most recent stable version of:
    • The Safari and Chrome browsers on MacOS
    • The Safari and Chrome browsers on iOS** and Android** and in the Fourth Android app and Fourth iOS app
  • The Fourth Inventory module (“r9”) is not currently supported in the Firefox browser
  • The Fourth Purchasing & Inventory module (“Adaco”) can only function in Microsoft Internet Explorer v11 and the most recent stable version of Microsoft Edge
  • The following are only supported in Microsoft Internet Explorer v11 running in compatibility mode:
    • Pension screens of the Payroll module (“People System”)
    • The Fourth Purchase-to-Pay module (“Trade Simple”)
  • Fourth Analytics:
    • All features are also supported in the most recent stable version of the Safari and Chrome browsers on MacOS
    • For dashboard viewing only, Fourth Analytics is also supported in the most recent stable version of the Safari and Chrome bro wsers on iOS** and Android** but not in the Fourth Android app or Fourth iOS app
  • The Fourth Applicant Tracking module (“ATS”) is currently only supported in the Chrome browser

*Older versions of Microsoft Internet Explorer are known to have heightened security risks: We strongly advise you to upgrade this browser to v11.

**See below for specifications

NB: We do not test or support our core solutions on MacOS, Linux, iOS, Android, or any other desktop or mobile browsers or operating systems not listed above. If you choose to use an unsupported operating system, browser, or version your ability to use the relevant solution may be adversely affected.

 
 

Mobile Applications

  • Counting application
  • Employee Self Service (“ESS”) application
  • Menu Cycles application
  • My Schedule application
  • Ordering application
  • Receiving application

iOS environment

  •  iPhone and Tablets
    • With 64-bit processors (e.g. iPhone 5s, iPhone SE and more recent models)
    • And on the iPad Mini and iPad (4G)
  • iOS version 11 or higher
  • The most recent stable version of:
    • the Fourth iOS app; or
    • the Safari browser; or
    • the Chrome browser

Android environment

  • Phones and Tablets
    • Minimum screen density: “hdpi” (~240dpi)
    • Minimum screen size: “large”
  • Android version “Marshmallow” (6.0) or higher
  • The most recent stable version of:
    • the Fourth Android app; or
    • the Chrome browser

Please note the following exceptions:

  • The Menu Cycles application is currently only supported in the most recent stable version of the Safari or Chrome browsers on iOS or Android tablets
  • The Ordering, Receiving, and Counting applications are not currently supported in the Safari or Chrome browsers on iOS or Android devices – please use the Fourth iOS or Android app

Desktop environments

We also support many of its mobile applications, including Menu Cycles, in the following desktop environments:

  • Microsoft Internet Explorer v11 on Windows (except for the Counting and My Schedule applications); or
  • The most recent stable version of:
    • the Chrome browser on Windows;
    • the Firefox browser on Windows (except for the Ordering, Receiving, and Counting applications); or
    • the Safari browser on MacOS (except for the Counting application)

NB: We do not test or support our mobile solutions on any other desktop or mobile browsers or operating systems. If you choose to use an unsupported operating system, browser, or version your ability to use the relevant solution may be adversely affected.
 
 

Network configuration

Network communication requirements

The Software-as-a-Service (SaaS) solutions are intended to be easily consumable from a suitable client device with a supported web browser or appropriate mobile app, and public Internet access (i.e. HTTP, HTTPS). This should require little or no configuration for customers that allow this access by default. Customers utilising user devices located behind firewalls and/or proxy servers that restrict this access must enable this communication to us.

Purchasing & Inventory (“Adaco”) customers will additionally require access to TCP port 444.

Note that some non-application-orientated elements of the solution (such as integrations, data uploads/downloads, feeds etc.) may require additional connectivity above and beyond standard web connections. Our customer services or implementation teams will be able to assist with this, as required.

NB: If your firewall, proxy, or Internet services load balance connectivity across multiple external IP addresses it is possible that some services may be negatively impacted. This is because some elements of our services require a persistent client IP address for the length of the session. Our customer services or implementation teams can discuss the needed configuration with the customer’s technical team if this is the case.

Network quality

As with any online service, the lower the client-to-our network latency and the higher the network bandwidth, the better the solution will perform. We continues to develop our software to operate optimally over all connectivity types but it is not possible to specify a maximum supported latency as this will very much depend on the available bandwidth, usage pattern, nature of the transaction, and end user expectation. Please speak with our customer services or implementation team for additional support.

Note: A good quality Internet connection is required. We cannot assure service on a connection that is over-utilized and hence subject to significant loss or error.

Network bandwidth

It is not possible for us to state generic minimum or recommended bandwidth requirements, as every scenario will differ in terms of customer usage patterns, users, sites, process etc. Our services are however designed to deliver an interactive and rich media experience and hence broadband equivalent minimum speeds of 1Mbps downstream / 0.5Mbps upstream should be assumed for any user-facing service.

Requirements will obviously increase with the number of users and concurrent use at a location. Our customer services and implementation teams have experience of many real-world implementations and will be able to provide further assistance based on similar use-cases.